Bad day at the office

Well, everything started off promisingly enough. I had already cleaned the popbumpers, so all I had to do was reinstall them. Or so I thought.

I had bought new mylar trim platters to replace the dirty and desintegrated old ones, so I started with cutting to of them to size. They need to have a corner cut out to fit around some posts that are really close to the bumper. Then I started installing the first popbumper. The base plate first, then the switch and then the popbumper body with the new mylar trim. Not good…

The mylar trim plate doesn't sit right

You can clearly see that the trim is lifted up about half a centimeter. Now way that’s right… So I dismantled the body again and had a close look at it all.

The holes for the baseplate rod guides are to small

So the holes in the trim are too small. I should have noticed that earlier. I checked on the website of the place where I had bought them but since they only had one-size-fits-all, there’s nothing much I can do. So happy I just bought a new multi=tool!

Leeloo Dallas multi-tool 😀

So with a bit of finesse I managed to widen the hole and now the trim fits perfectly.

Fits like a charm

Rince and repeate three times and finally the popbumpers are installed.

All popbumpers finally reseated.

That took a lot longer than expected and since I only had about 20 minutes left before I had to go, I thought to quickly install the new outhole switch. I soldered a diode over the appropriate contacts and went to get the bracket to fix it to the bottom of the playfield.

The bracket was no where to be found! Where did I put it. Where could it be. Then I remembered that I checked the bracket on the playfield to see which were the correct holes last time I worked it and I might have left it there when I left. And today while turning the playfield over to get tot the popbumpers it might have fallen off. After 5 minutes of sitting on my knees, clearing out my toolbox bit by bit, I still hadn’t found it. Finally I noticed something weird with one of the flipper assemblies, there was a piece of metal sticking out that shouldn’t be there. Sure enough it was the bracket that got lodged between the playfield and the flipper assembly. I had found it!

So I started screwing it in place only to notice one of the screws and bolts for the microswitch itself was missing. Where was it? Still on the old switch! So into the trashcan I went. Luckily I hadn’t emptied the trash yet, so it was still in there and I could recuperate the screw and bolt. With the new switch finally installed I soldered the leads to it and now the bottom part of the playfield is done.

New outhole switch finally installed

So with all that bad luck and stupid mistakes, an hours worth of work took me over three hours to do. Bad day at the office indeed!



Leave a Reply